技术宅改变世界 技术宅改变世界

升级系统自带的gcc版本

in Dev read (460) 文章转载请注明来源!

centos6默认yum安装gcc版本太低(其实我也不想用6),nginx的一般要使用gcc4.8+以上版本才能完全发挥他的性能,并且有些软件编译时使用低版本gcc会报错。

个人安装环境centos6,其他环境请自行测试。

GCC_VERSION='4.8.5'
#gcc版本号 http://ftp.gnu.org/gnu/gcc/
wget http://ftp.gnu.org/gnu/gcc/gcc-${GCC_VERSION}/gcc-${GCC_VERSION}.tar.bz2
tar -jxvf gcc-${GCC_VERSION}.tar.bz2
cd gcc-${GCC_VERSION}
./contrib/download_prerequisites
mkdir gcc-build-${GCC_VERSION}
cd gcc-build-${GCC_VERSION}
../configure -enable-checking=release -enable-languages=c,c++ -disable-multilib
make -j $(awk '/processor/{i++}END{print i}' /proc/cpuinfo)
#编译如果遇到内存不足的情况,可以将-j置为1再试一次
make install

安装遇到问题

make[1]: *** [stage1-bubble] Error 2
#解决方法
sudo yum -y install glibc-devel gcc-c++
gcccentos6
发表新评论
博客已萌萌哒运行
© 2020 • Powered by Typecho • Theme for yotu
PREVIOUS NEXT
雷姆
拉姆